Arduino

From MusiKiwi

Jump to: navigation, search

Windows Installation

  • download & install regular Arduino IDE

http://arduino.cc/en/Main/Software

  • get Atmel Studio

http://www.atmel.com/tools/ATMELSTUDIO.aspx

In Atmel Studio:

  • Tools -> Extension Manager
    • search for 'serial', install 'TerminalWindow'
  • Tools -> External Tools
    • Title: avrdude
    • Command: C:\Program Files (x86)\Arduino\hardware\tools\avr\bin\avrdude.exe
    • Arguments: -C"C:\Program Files (x86)\Arduino\hardware\tools\avr\etc\avrdude.conf" -patmega168 -carduino -P\\.\COM3 -b19200 -Uflash:w:"$(ProjectDir)Debug\$(ItemFileName).hex":i

avrdude on the Command Line

The easiest way to figure out what the avrdude command line arguments should look like is to use the Arduino IDE.

  1. File->Preferences
  2. Show verbose output during: 'check' upload

Now click upload and examine the output from avrdude. An example for the Arduino Diecimila is here:

  avrdude -C "C:\Program Files (x86)\Arduino\hardware\tools\avr\etc\avrdude.conf" 
  -p atmega168 -c arduino -P \\.\COM3 -b19200 -Uflash:w:"blink.hex":i

prog_char

  // const prog_char *arr;
  const char PROGMEM *arr;
Personal tools